在调用API4.12的时候报错 view.then is not a function

报错截图:

00.png

 
但将引用的JSAPI换成4.4版本的就不会报错了,是更新API的时候调整了什么吗?
希望大佬赐教(抱拳)!
已邀请:

敖婧

赞同来自: 蒋元甲甲

改成view.when就可以了,具体哪个版本改了忘记了,大概是4.5到4.7这三个版本中,某一个版本起将view.then方法改成了view.when

要回复问题请先登录注册