SenceLayer在不同版本API加载异常

三维模型采用slpk的方式发布为SenceServer,采用4.11版本可以正常加载,但采用高于4.11版本API加载报错如图:
111.png

采用三维模型GDB方式发布成SenceServer不同版本均可加载,但模型存在黑模,效果很差,标准方式都是打包为slpk发布三维模型,用portal浏览模型显示正常,但采用api前端加载高于4.11版本均报错,没有在4.11到4.12以上版本API变更说明里面找到有关sencelayer的变更,当前项目因用到水面特效及视线分析等功能均在高版本4.12及以后才有,但模型加载报错,求分析 ,下图为4.11版本加载正常模型:
222.png
已邀请:

许丹石 - Esri技术支持工程师

赞同来自:

模型是如何从原始数据变为SceneServer的。能否说明用作打包的ArcGIS Pro是否已经使用了最新的2.5版本?
发布到的ArcGIS Enterprise企业级服务器是否已经使用最新的10.8版本?
我的观点是一旦你使用最新版本,这些异常问题不存在了。

要回复问题请先登录注册